Jump to content
Do NOT post your private starlink information and/or Billing information on this forum - There is 200% no need to post your private information for assistance. ×
Do NOT post your private starlink information and/or Billing information on this forum - There is 200% no need to post your private information for assistance.

Can't Connect to Skylight Photo Frame


Recommended Posts

I've tried unplugging Starlink router and Skylight photo frame several times. A troubleshooter for the latter said to go to Settings/Reset WiFi/Choose Starlink/enter password. I've tried this several times and it says "signal lost" or "aborted" every time even if it's right beside the router. It never gets to the point where I can enter a password. Does anyone else have a photo frame like that and did you get it to work? I also tried rebooting a couple of times when that option showed up. 

Link to comment
Share on other sites

  • 2 months later...

Replying to people whose frames suddenly are not connected to internet. Mine did that, too! It's still not working. My sister's frame did the same thing in the same week as mine! I think there is a major glitch that affected our fames, and they are not telling us. The only solution is to do a hard re-set!? Unacceptable. They SAY it will not lose our photos, but when the photos are restored, they will be out of order.  I want to hear from Skylight about what is going on! I'm not doing this re-set until I have more answers. Has anyone done the re-set? What was your experience?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...